Webdesign-Forum

Normale Version: CoolURI - tt-news mögen sich nicht auf meiner Seite
Du siehst gerade eine vereinfachte Darstellung unserer Inhalte. Normale Ansicht mit richtiger Formatierung.
Hi Wolfgang,

so, nach Längerem steh ich wieder mal komplett an:

Ich hab eine Seite mit tt_news laufen, wo ich die URLs weder mit realurl noch cooluri so hinbringe, dass es mit tt_news funktioniert.

Bei realurl schafft er es nicht, die Links zu den tt_news - Singlebeiträgen als nice-url zu rendern (bei den normalen Seiten komischerweise schon) und deswegen hab ich (nach elendslangem Herumprobieren mit der realurl_conf) jetzt cooluri probiert, die mir von der Konfiguration mit der XML-Datei schon mehr zusagt.

Hier schafft er zwar die URLs auch von den tt_news-Beiträgen in nice-urls umzuwandeln, aber wenn man versuch, so einen Link aufzurufen kriegt man:

zB.:

Link: http://www.wohninsider.at/top-news/news-...-galerien/


Ergebnis:


Zitat:Page Not Found

The page did not exist or was inaccessible. Reason: Segment "warendorf-mit-event-store-in-wiener-ringstrassen-galerien" was not a keyword for a postVarSet as expected on page with id=59.

In der Liste der gecachten URLs zeigt er mir aber schön brav alle Parameter:


Zitat:top-news/news-details/warendorf-mit-event-store-in-wiener-ringstrassen-galerien/                  

cHash=f8ce47cf641ee5b6a079a141f7abff9a&id=59&tx_ttnews[tt_news]=356


Alle andern "normalen" Content-Seiten funktionieren ohne Probleme. Ich krieg die Krise. Huh

Hast Du hier schon Erfahrungen gemacht, wo ich den Fehler suchen könnte? Liegt's vielleicht an den rewrite-Einstellungen in der .htacess? Da er aber alle normalen Seiten ohne Probleme findet, sollten die Definitionen eigentlich ok sein.

Hab jetzt momentan die cooluri abgedreht und lebe mit index.php?id=... URLs, da die Seite online ist. Aber ich sollte das schnell fixen.

Bitte um Hilfe.

Vielen Dank im Vorhinein und Lg, Hannes
Zur Info noch meine aktuellen Versionen:

Typo3: 6.2.3
tt_news: 3.6.0
cooluri: 1.0.37

Danke und lg, Hannes
Mittlerweile:

Typo3: 6.2.5

Hab ein Core-Update gemacht. ;-)