Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Probleme mit CoolURI
#1
Hallo erstmal an alle,

wie schon oben beschrieben habe ich Probleme mit CoolURI.
Zuerst wurden meine URI´s nicht "konvertier" also verschönert. Nach Suche im Forum fand ich dan den tipp das"config." vor den Attributen im template-setup zuentfernen. Funktionierte auch soweit, nur dass dann meine Seiten nicht gefunden wurden und mit einem 404 Error ausgegeben wurden. Daraufhin benutze ich ebenfals viele Lösungsvorschläge hier im Forum, doch keine half. Deshabl hoffe ich mal das mein Fall nicht zu Starck von den anderen abweicht.

Erstmal benutze ich Typo3 4.5.6 habe das mit hilfe dem tutorial auch soweit installiert und konfiguriert. Typo3 läuft bei mir auf einem lokalen Zend Server. Da ich heir schon einiges gelesen habe versuche Ich direkt soviele Informationen mitzuteilen wie es geht.

Zunächst meine CONFIG datei im Typoscript-Tempaltes ordner
    TYPOSCRIPT Programming
  1. config {
  2. admPanel = 0
  3. headerComment (
  4. Diese Seite wurde erstellt von:
  5.  
  6. )
  7.  
  8. doctype = <!DOCTYPE html>
  9. //xhtmlDoctype = xhtml_trans
  10. //htmlTag_langKey = de_DE
  11. xhtml_cleaning = all
  12. //xmlprologue = none
  13. disablePrefixComment = 1
  14. index_enable = 0
  15. //baseURL = http://localhost/typo3/
  16. //absRefPrefix = http://localhost/typo3/
  17. spamProtectEmailAddresses = ascii
  18. spamProtectEmailAddresses_atSubst = (at)
  19.  
  20. removeDefaultJS = external
  21. inlineStyle2TempFile = 1
  22.  
  23. noScaleUp = 1
  24. meaningfulTempFilePrefix = 50
  25.  
  26. sys_language_uid = 0
  27. language = de
  28. locale_all = de_DE
  29.  
  30. }
  31. //config.baseURL = http://localhost/typo3/
  32. //config.absRefPrefix = http://localhost/typo3/
  33. //config.tx_cooluri_enable = 1
  34. //config.redirectOldLinksToNew = 1


ich habe um meine Seiten wiederzusehen und weiterzuarbeiten die Zeilen für CoolUri auskommentiert. Also daran liegt es nicht ^^

dann habe ich die .htaccess datei umbenannt und auch in einem Rewrite Befehl das fehlende / eingefügt (war ebenfals als Lösung angeben)
also hier die htaccess datei:
Code:
#####
#
# Example .htaccess file for TYPO3 CMS - for use with Apache Webserver
#
# This file includes settings for the following configuration options:
#
# - Compression via TYPO3
# - Settings for mod_rewrite (URL-Rewriting)
# - PHP optimisation
# - Miscellaneous
#
# If you want to use it, you have to copy it to the root folder of your TYPO3 installation (if its
# not there already) and rename it to '.htaccess'. To make .htaccess files work, you might need to
# adjust the 'AllowOverride' directive in your Apache configuration file.
#
# IMPORTANT: You may need to change this file depending on your TYPO3 installation!
#
# Lines starting with a # are treated as comment and ignored by the web server.
#
# You should change every occurance of TYPO3root/ to the location where you have your website in.
# For example:
# If you have your website located at http://mysite.com/
# then your TYPO3root/ is just empty (remove 'TYPO3root/')
# If you have your website located at http://mysite.com/some/path/
# then your TYPO3root/ is some/path/ (search and replace)
#
# You can also use this configuration in your httpd.conf, but then you have to modify some lines,
# see the comments (search for 'httpd.conf')
#
# Questions about this file go to the matching Install mailing list, see
# http://typo3.org/documentation/mailing-lists/
#
####


### Begin: Compression via TYPO3 ###

# Compressing resource files will save bandwidth and so improve loading speed especially for users
# with slower internet connections. TYPO3 can compress the .js and .css files for you.
# 1) Uncomment the following lines and
# 2) Set $TYPO3_CONF_VARS['BE']['compressionLevel'] = '9'

#<FilesMatch "\.js\.gzip$">
#    AddType "text/javascript" .gzip
#</FilesMatch>
#<FilesMatch "\.css\.gzip$">
#    AddType "text/css" .gzip
#</FilesMatch>
#AddEncoding gzip .gzip

### End: Compression via TYPO3 ###


### Begin: Browser caching of ressource files ###

# Enable long browser caching for JavaScript and CSS files.

# This affects Frontend and Backend and increases performance.
# You can also add other file extensions (like gif, png, jpg), if you want them to be longer cached, too.

<FilesMatch "\.(js|css)$">
  <IfModule mod_expires.c>
    ExpiresActive on
    ExpiresDefault "access plus 7 days"
  </IfModule>
  FileETag MTime Size
</FilesMatch>

### End: Browser caching of ressource files ###


### Begin: Settings for mod_rewrite ###

# You need rewriting, if you use a URL-Rewriting extension (RealURL, CoolUri, SimulateStatic).

<IfModule mod_rewrite.c>

# Enable URL rewriting
RewriteEngine On

# Change this path, if your TYPO3 installation is located in a subdirectory of the website root.
#RewriteBase /

# Rule for versioned static files, configured through:
# - $TYPO3_CONF_VARS['BE']['versionNumberInFilename']
# - $TYPO3_CONF_VARS['FE']['versionNumberInFilename']
# IMPORTANT: This rule has to be the very first RewriteCond in order to work!
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+)\.(\d+)\.(php|js|css|png|jpg|gif|gzip)$ $1.$3 [L]

# Stop rewrite processing, if we are in the typo3/ directory.
# For httpd.conf, use this line instead of the next one:
# RewriteRule ^/TYPO3root/(typo3/|t3lib/|fileadmin/|typo3conf/|typo3temp/|uploads/|favicon\.ico) - [L]
RewriteRule ^(typo3/|t3lib/|fileadmin/|typo3conf/|typo3temp/|uploads/|favicon\.ico) - [L]

# Redirect http://example.com/typo3 to http://example.com/typo3/index_re.php
# and stop the rewrite processing.
# For httpd.conf, use this line instead of the next one:
# RewriteRule ^/TYPO3root/typo3$ /TYPO3root/typo3/index.php [L]
RewriteRule ^typo3$ typo3/index_re.php [L]

# If the file/symlink/directory does not exist => Redirect to index.php.
# For httpd.conf, you need to prefix each '%{REQUEST_FILENAME}' with '%{DOCUMENT_ROOT}'.
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

# Main URL rewriting.
# For httpd.conf, use this line instead of the next one:
# RewriteRule .* /TYPO3root/index.php [L]
RewriteRule .* /index.php [L]

</IfModule>

### End: Settings for mod_rewrite ###


### Begin: PHP optimisation ###

# If you do not change the following settings, the default values will be used.

# TYPO3 works fine with register_globals turned off.
# This is highly recommended, if your web server has it turned on.
#php_flag register_globals off

### End: PHP optimisation ###



### Begin: Miscellaneous ###

# Make sure that directory listings are disabled.
#Options -Indexes

### End: Miscellaneous ###


# Add your own rules here.
# ...
soweit dazu, ebenfals die CoolURIConf.xml in den richtigen Ordner geschoben diese psote ich erstmal nciht, sit jetzt schon zu lange und hoffe dass der Fehler oben zufinden ist oder an sonstigen einstellungen liegt. Zur Info zum Schluß: bin ein Azubi der Informatik im 1jahr und arbeite jetzt seit einer Woche mit Typo3 von daher könnte es auch eins chlichter Anfängerfehler sein,

bis dahin vielen dank im Voraus
MfG André Richter
Das, wobei unsere Berechnungen versagen, nennen wir Zufall.
Zitieren
#2
Ich habe mal Formatierungen für den Code eingefügt.

Du musst aufjedenfall baseURL verwenden. AbsRefPrefix würde ich allerdings weg lassen.

MfG René
Systemadministrator, Webentwickler

pantanet.de - pantamedia.com - gosna.de

Wishlist
Zitieren
#3
danke für die schnelle Antowort,
ich werd dann mal alles umändern, kann dir ddann morgen sagen ob es geklappt hat.
Das, wobei unsere Berechnungen versagen, nennen wir Zufall.
Zitieren
#4
Habe den Code soweit eingefügt. CoolURI schafft es zwar jetzt wieder die URI´s sauber auszugeben, doch werden diese wieder nicht gefunden.

Kann es damit zusammen hängen, dass ich die Typo3 daten nicht direkt im htdocs-verzeichnisses liegen habe. Im moment liegen sie mir bei C:\Projects
dieses verzeichnis zeigt aber mit einer Alias auf das htdocs-verzeichnis meines Zend-Servers, hier der passende auszug aus der conf-datei meines Servers:

<Location /typo3>
Options Indexes
Order deny,allow
Allow from all
</Location>

Alias /typo3 "C:\Projects\typo3"

soweit findet er auch die seiten in Project Ordner ganz normal, könnte CoolURI damit ein problem haben? oder muss ich ihm selber angeben wo die daten richtig liegen?
Das, wobei unsere Berechnungen versagen, nennen wir Zufall.
Zitieren
#5
also du gibst im Browser z.b. http://localhost/typo3/ ein und bekommst dann deine Seite zu sehen?

Dann musst du die rewrite base in der .htaccess ändern.

Code:
# Change this path, if your TYPO3 installation is located in a subdirectory of the website root.
#RewriteBase /

zu

Code:
# Change this path, if your TYPO3 installation is located in a subdirectory of the website root.
RewriteBase /typo3/
MfG René
Systemadministrator, Webentwickler

pantanet.de - pantamedia.com - gosna.de

Wishlist
Zitieren
#6
um meine seite aufzurufen muss ich http://localhost/typo3/index.php im Browser eingeben

reicht es dann auch RewriteBase /typo3/zu schreiben?

-----------------------

PS: hab den Code jetzt mal versucht und bekomme diese Fehlermeldung

Not Found

The requested URL /typo3/ueber-uns/ was not found on this server.


Passiert auch mit jeder seite.
Wenn ich die einzelnen Seiten über das Seitenmodul aufrufe kann ich sie sehen, erst wenn ich auf der angezeigten seite, auf die anderen Seiten springen will findet er diese nicht.
Das, wobei unsere Berechnungen versagen, nennen wir Zufall.
Zitieren
#7
BaseURL ist auf "http://localhost/typo3/"?

Die Links sehen auch so aus?

Code:
<a href="uber-uns/">Über uns</a>

Die htaccess heißt auch ".htaccess"?
MfG René
Systemadministrator, Webentwickler

pantanet.de - pantamedia.com - gosna.de

Wishlist
Zitieren
#8
ja die base URL sieht so aus also in der config datei

ja hab wie im tutorial die _-htaccess datei nach .htaccess genannt, mit hilfe der eingabeauffoderung

so sieht der Quelltext (in Firefox) aus:
div class="hlist"><ul><li><a href="home/" onfocus="blurLink(this);">Home</a></li><li class="active"><strong>Über Uns</strong></li><li><a href="produkte/" onfocus="blurLink(this);">Produkte</a></li><li><a href="anfahrt/" onfocus="blurLink(this);">Anfahrt</a></li><li><a href="gaestebuch/" onfocus="blurLink(this);">Gästebuch</a></li></ul></div

also nicht ganz genau wie du es beschrieben hast könnte es daran liegen fals ja wo kann ich das ändern? habe wie im tutorial das YAML Template mit TempalVoila gemappt
Das, wobei unsere Berechnungen versagen, nennen wir Zufall.
Zitieren
#9
Nein, so ist es in ordnung, wusste nicht so genau wie es aussieht, da ich mein CoolURI so konfiguriert habe das es .html am ende immer stehen hat, also ueber-uns.html statt ueber-uns/.

Daran sollte es nicht liegen.

So ... dann mal weiter im Programm:

die .htacces liegt auch im TYPO3 Verzeichnis, vermute ich mal...

Nun ist die Frage warum dies nicht funktioniert folgende Gründe könnte es haben:

mod_rewrite ist nicht verfügbar

Öffne in die "httpd.conf" (bei XAMPP im Verzeichnis "apache/conf") und suche die Zeile:

Code:
LoadModule rewrite_module modules/mod_rewrite.so

Stelle sicher das keine Raute (#) davor steht.

Die Zeile könnte sich in anderen Installationen auch in einer anderen Konfigurationsdatei befinden. Bei linux z.B. muss man in der Datei "/etc/sysconfig/apache2" die Liste unter "APACHE_MODULES=" um ein " rewrite " erweitern.

Das benutzen einer htaccess ist nicht erlaubt

In der Directory Anweisung deines Aliases die Option "AllowOverride All" setzen.

    APACHE Programming
  1. <Directory "C:/Projects/typo3">
  2. ...
  3. AllowOverride All
  4. ...
  5. </Directory>



MfG René
Systemadministrator, Webentwickler

pantanet.de - pantamedia.com - gosna.de

Wishlist
Zitieren
#10
Also bei meinem Zend Server unter Windows 7, war die datei ebenfalls im appache ordner und es steht KEINE raute(#) da :S

Es ist aber ein appache2, wenn das von bedeutung ist

die access datei liegt hier: C:\Projects\typo3
Das, wobei unsere Berechnungen versagen, nennen wir Zufall.
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 2 Gast/Gäste