Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Probleme mit CoolURI
#31
Wie hast du das in deine zend.conf gepackt?

Was sagt das error.log ("\Zend\Apache2\logs")?

Meine zend.conf sieht übrigends so aus:
    APACHE Programming
  1. <Location /server-info>
  2. SetHandler server-info
  3. Order deny,allow
  4. Deny from all
  5. Allow from 127.0.0.1
  6. </Location>
  7.  
  8. <Location /server-status>
  9. SetHandler server-status
  10. Order deny,allow
  11. Deny from all
  12. Allow from 127.0.0.1
  13. </Location>
  14.  
  15. LoadModule zend_enabler_module "C:\Program Files\Zend\ZendServer\bin\ZendEnablerApache.dll"
  16. ZendEnablerConfig "C:\Program Files\Zend\ZendServer\etc\ZendEnablerConf.xml"
  17. AddHandler zend-enabler-script .php
  18. AddType application/x-httpd-php .php
  19.  
  20. <Location /phpMyAdmin>
  21. Order deny,allow
  22. Allow from all
  23. </Location>
  24.  
  25. Alias /phpMyAdmin "C:\Program Files\Zend\phpMyAdmin"
  26.  
  27. Listen 20080
  28.  
  29. NameVirtualHost *:20080
  30.  
  31. <VirtualHost *:20080>
  32. DocumentRoot "E:\Eclipse\PHP\TYPO3"
  33.  
  34. <Directory "E:\Eclipse\PHP\TYPO3">
  35. AllowOverride All
  36. Allow from all
  37. </Directory>
  38. </VirtualHost>
  39.  
  40. AllowEncodedSlashes On
  41.  
  42.  
  43. Listen 10081
  44.  
  45. NameVirtualHost *:10081
  46.  
  47. <VirtualHost *:10081>
  48. Alias /ZendServer "C:\Program Files\Zend\ZendServer\GUI\html"
  49. DocumentRoot "C:\Program Files\Zend\ZendServer\GUI\html"
  50. RewriteEngine On
  51. RewriteRule ^/$ /ZendServer/ [R]
  52. RewriteRule ^/Login$ /ZendServer/Login [R]
  53. <Directory "C:\Program Files\Zend\ZendServer\GUI\html">
  54. AllowOverride All
  55. Allow from all
  56. </Directory>
  57. </VirtualHost>
  58.  
  59. AllowEncodedSlashes On

MfG René
Systemadministrator, Webentwickler

pantanet.de - pantamedia.com - gosna.de

Wishlist
Zitieren
#32
Sehe ich das jetzt richtig? Ihr schlagt euch seit Stunden mit diesem CoolURI-Problem rum bei einer TYPO3-Installation auf einem lokalen PC, bei der es völlig egal ist, ob sie SEO-freundliche URLs produziert, weil davon 'eh nichts ins Internet gelangt? Cool
Zitieren
#33
Einer meiner Dozenten hätte früher immer gesagt es gibt keine Probleme sondern herrausforderungen. Und eine solche geb ich ungern auf :-D

Gesendet von meinem HTC Desire HD mit Tapatalk
MfG René
Systemadministrator, Webentwickler

pantanet.de - pantamedia.com - gosna.de

Wishlist
Zitieren
#34
Meine Zend Datei sieht folgender maßen aus:


Location /server-info>
SetHandler server-info
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Location>

<Location /server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Location>

LoadModule zend_enabler_module "C:\Program Files (x86)\Zend\ZendServer\bin\ZendEnablerApache.dll"
ZendEnablerConfig "C:\Program Files (x86)\Zend\ZendServer\etc\ZendEnablerConf.xml"
AddHandler zend-enabler-script .php
AddType application/x-httpd-php .php

<Location /phpMyAdmin>
Order deny,allow
Allow from all
</Location>

Alias /phpMyAdmin "C:\Program Files (x86)\Zend\phpMyAdmin"

Listen 20080.

NameVirtualHost *:20080
<VirtualHost *:20080>
DocumentRoot "C:\Projects\typo3"
<Directory "C:\Projects\typo3">
AllowOverride All
Allow from all
</Directory>
</VirtualHost>

Listen 10081

NameVirtualHost *:10081

<VirtualHost *:10081>
Alias /ZendServer "C:\Program Files (x86)\Zend\ZendServer\GUI\html"
DocumentRoot "C:\Program Files (x86)\Zend\ZendServer\GUI\html"
RewriteEngine On
RewriteRule ^/$ /ZendServer/ [R]
RewriteRule ^/Login$ /ZendServer/Login [R]
<Directory "C:\Program Files (x86)\Zend\ZendServer\GUI\html">
AllowOverride All
Allow from all
</Directory>
</VirtualHost>

AllowEncodedSlashes O

Als Fehelr MEldung sagt er nur
Error
The request operation has failed!

und ind en logs steht das hier :

[Fri Oct 14 16:02:20 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Fri Oct 14 16:02:20 2011] [notice] Child 3020: Exit event signaled. Child process is ending.
[Fri Oct 14 16:02:21 2011] [notice] Child 3020: Released the start mutex
[Fri Oct 14 16:02:22 2011] [notice] Child 3020: All worker threads have exited.
[Fri Oct 14 16:02:22 2011] [notice] Child 3020: Child process is exiting
[Fri Oct 14 16:02:22 2011] [notice] Parent: Child process exited successfully.

ich habe heute ebenfals versucht ihn zustarten dazu gab er in der Error log keine Azeige aus.


@Wolfgang Wagner

Ich würde mal sagen ich mach das aus dem Lerneffekt^^, um künftige Probleme vllt selbst lösen zu können und möglich, dass der selbe Fehler, auch auf einen echten Webserver auftritt und dann ist es bessser schonmal eine/mehrere Lösungs ansätze parrat zuhaben. Smile
Das, wobei unsere Berechnungen versagen, nennen wir Zufall.
Zitieren
#35
hab den fehler gefunden ein "." war zu viel -.-

nur findet er jetzt nichteinmal mehr das backend, oder ich tipp die falsche URL dahin an :S
Das, wobei unsere Berechnungen versagen, nennen wir Zufall.
Zitieren
#36
Du musst nun folgende URLs verwenden

http://localhost:20800/ fürs Frontend
http://localhost:20800/typo3/ fürs Backend
MfG René
Systemadministrator, Webentwickler

pantanet.de - pantamedia.com - gosna.de

Wishlist
Zitieren
#37
Gut jetzt find ich das backend wieder, nur wieder neue fehler:
1. Mein Template ist "weg" alsod ie seite wird ohne Formatierung angezeigt und
2. sind URLS zwar wieder schön nur das selbe problem wie am anfang, dass er die seiten nicht findet :S

PS: Zu Fehler 1, nur IE macht schwierigkeiten denke das es zum späteren zeitpunkt des Tutorials darauf eingegangen wird.

Bleibt nur das er die Seiten wenn man im Hauptnav annavigiert nicht findet
Das, wobei unsere Berechnungen versagen, nennen wir Zufall.
Zitieren
#38
Hast du im Template die baseURL geändert? Die Rewritebase in der .htaccess hast du auch auskommentiert?

Dann evtl mal CoolURI und den Cache leeren
MfG René
Systemadministrator, Webentwickler

pantanet.de - pantamedia.com - gosna.de

Wishlist
Zitieren
#39
Immoment steht da:
config.baseURL = http://localhost/typo3/

ich nehm mal an das ich beim localhost die :20080 dranhängen muss, soll dann das typo3 da stehen bleiben?

und den chache leere ich eig nach jeder änderung
Das, wobei unsere Berechnungen versagen, nennen wir Zufall.
Zitieren
#40
nein, das typo3 weg und die ":20800" ran und dann sollte gut sein
MfG René
Systemadministrator, Webentwickler

pantanet.de - pantamedia.com - gosna.de

Wishlist
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste