Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
coolUri > page not found....
#1
Hallo,

komme einfach nicht weiter, habe einen neuen
provider .. und installiere wie gewohnt coolUri ..
alles wunderbar .. so die installation.

mein typoScript sieht so aus:

config.baseURL = http://www.irgendwas.de/
config.tx_cooluri_enable=1
config.redirect01dLinksToNew=1

jetzt müsste ich ja "nur" die .htaccess zum
laufen bringen .. der provider sagt mir müsste
nur im root verzeichnis diese "aktivieren" ...
jetzt bin ich so durcheinander und weiss nicht
wo, da die ordner struktur anders aussieht wie
wie beim alten provider ...

[Bild: ansichty.jpg]

... vielleicht ist ja meine .htaccess auch falsch beschrieben?!

die sieht so aus:

Zitat:#####
#
# Example .htaccess file for TYPO3 CMS - for use with Apache Webserver
#
# This file includes settings for the following configuration options:
#
# - Compression via TYPO3
# - Settings for mod_rewrite (URL-Rewriting)
# - PHP optimisation
# - Miscellaneous
#
# If you want to use it, you have to copy it to the root folder of your TYPO3 installation (if its
# not there already) and rename it to '.htaccess'. To make .htaccess files work, you might need to
# adjust the 'AllowOverride' directive in your Apache configuration file.
#
# IMPORTANT: You may need to change this file depending on your TYPO3 installation!
#
# Lines starting with a # are treated as comment and ignored by the web server.
#
# You should change every occurance of TYPO3root/ to the location where you have your website in.
# For example:
# If you have your website located at http://mysite.com/
# then your TYPO3root/ is just empty (remove 'TYPO3root/')
# If you have your website located at http://mysite.com/some/path/
# then your TYPO3root/ is some/path/ (search and replace)
#
# You can also use this configuration in your httpd.conf, but then you have to modify some lines,
# see the comments (search for 'httpd.conf')
#
# Questions about this file go to the matching Install mailing list, see
# http://typo3.org/documentation/mailing-lists/
#
####


### Begin: Compression via TYPO3 ###

# Compressing resource files will save bandwidth and so improve loading speed especially for users
# with slower internet connections. TYPO3 can compress the .js and .css files for you.
# 1) Uncomment the following lines and
# 2) Set $TYPO3_CONF_VARS['BE']['compressionLevel'] = '9'

#<FilesMatch "\.js\.gzip$">
# AddType "text/javascript" .gzip
#</FilesMatch>
#<FilesMatch "\.css\.gzip$">
# AddType "text/css" .gzip
#</FilesMatch>
#AddEncoding gzip .gzip

### End: Compression via TYPO3 ###


### Begin: Browser caching of ressource files ###

# Enable long browser caching for JavaScript and CSS files.

# This affects Frontend and Backend and increases performance.
# You can also add other file extensions (like gif, png, jpg), if you want them to be longer cached, too.

<FilesMatch "\.(js|css)$">
<IfModule mod_expires.c>
ExpiresActive on
ExpiresDefault "access plus 7 days"
</IfModule>
FileETag MTime Size
</FilesMatch>

### End: Browser caching of ressource files ###


### Begin: Settings for mod_rewrite ###

# You need rewriting, if you use a URL-Rewriting extension (RealURL, CoolUri, SimulateStatic).

<IfModule mod_rewrite.c>

# Enable URL rewriting
RewriteEngine On

# Change this path, if your TYPO3 installation is located in a subdirectory of the website root.
RewriteBase /

# Rule for versioned static files, configured through:
# - $TYPO3_CONF_VARS['BE']['versionNumberInFilename']
# - $TYPO3_CONF_VARS['FE']['versionNumberInFilename']
# IMPORTANT: This rule has to be the very first RewriteCond in order to work!
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+)\.(\d+)\.(php|js|css|png|jpg|gif|gzip)$ $1.$3 [L]

# Stop rewrite processing, if we are in the typo3/ directory.
# For httpd.conf, use this line instead of the next one:
# RewriteRule ^/TYPO3root/(typo3/|t3lib/|fileadmin/|typo3conf/|typo3temp/|uploads/|favicon\.ico) - [L]
RewriteRule ^(typo3/|t3lib/|fileadmin/|typo3conf/|typo3temp/|uploads/|favicon\.ico) - [L]

# Redirect http://example.com/typo3 to http://example.com/typo3/index_re.php and stop the rewrite processing.
# For httpd.conf, use this line instead of the next one:
# RewriteRule ^/TYPO3root/typo3$ /TYPO3root/typo3/index.php [L]
RewriteRule ^typo3$ typo3/index_re.php [L]

# If the file/symlink/directory does not exist => Redirect to index.php.
# For httpd.conf, you need to prefix each '%{REQUEST_FILENAME}' with '%{DOCUMENT_ROOT}'.
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

# Main URL rewriting.
# For httpd.conf, use this line instead of the next one:
# RewriteRule .* /TYPO3root/index.php [L]
RewriteRule .* index.php [L]
#RewriteRule .* /index.php [L]

</IfModule>

### End: Settings for mod_rewrite ###


### Begin: PHP optimisation ###

# If you do not change the following settings, the default values will be used.

# TYPO3 works fine with register_globals turned off.
# This is highly recommended, if your web server has it turned on.
#php_flag register_globals off

### End: PHP optimisation ###



### Begin: Miscellaneous ###

# Make sure that directory listings are disabled.
#Options -Indexes

### End: Miscellaneous ###


# Add your own rules here.
# ...


und diese habe ich dann in den typo3-ordner abgelegt


kann mir jemand helfen?!


Zitieren
#2
Du musst die in deinen htdocs-Ordner legen.
Zitieren
#3

:-) ...ok .. werde es gleich nach dem mittagsessen machen
und dann berichten .... :-)
Zitieren
#4

ich habe es doch jetzt gemacht :-) ... und es klappt ...
muchos gracias :-)
Zitieren
#5
Sad 
hallo zusammen,

ich habe mich an die vorgehensweise vom tutorial gehalten, bekomme ebenfalls eine page not found meldung und finde keinen lösungsansatz mehr...nach 3 stunden dr. google befragen. Sad

der einzige unterschied ist, dass ich für meine typo3-installation ein unterverzeichnis namens t3new besitze.

im "t3new-verzeichnis" liegt die htaccess-datei. providerseitig habe ich alles so konfiguriert, dass der pfad C:\inetpub\vhosts\domain.de\httpdocs\t3new ohne die extension cooluri meiner domain http://meinedomain.de entspricht und vorher alles normal aufrufbar war.

hat jemand eine ahnung woran mein fehler liegen könnte?

mit der bitte um hilfe

mfg robert1010
Zitieren
#6
realurl und simulate-static-url schmeißen die selben fehler, ich bin noch am verzweifeln...hat keiner eine idee oder mag support leisten?
Zitieren
#7
Hast Du auch sicher im TS die richtige Url gesetzt?
z.B.
Code:
config.baseURL = http://meinedomain.de/t3new/
Zitieren
#8
Du hast geschrieben

Zitat:im "t3new-verzeichnis" liegt die htaccess-datei. providerseitig habe ich alles so konfiguriert, dass der pfad C:\inetpub\vhosts\domain.de\httpdocs\t3new ohne die extension cooluri meiner domain http://meinedomain.de entspricht und vorher alles normal aufrufbar war.

Verstehe ich das richtig:

T3 liegt zwar im Verzeichnis t3new, aber die Website wird direkt über die Domain aufgerufen, ohne /t3new hinten dran?

Dann muss die baseURL natürlich http://meinedomain.de/ lauten.
Zitieren
#9
hallo und danke für die antworten,

die baseurl habe ich gesetzt wie wolfgang beschrieben hat.

hintergrund war: verwende ich config.baseURL = http://meinedomain.de/t3new/ in meinem TS und deaktiviere die extension werden meine pfade zu den css dateien falsch gesetzt.

ich habe das gefühl das problem liegt an meiner .htaccess...!? auch wenn ich hier den unterordner bei RewriteBase und RewriteRule angebe, waren meine versuche an dieser stelle ebenfalls vergebens.

fazit ist, egal ob ich eine oder keine htaccess besitze...immer kommt die selbe "not found" fehlermeldung....kann es sein das mein provider da probleme macht? oder ist der ansatz falsch?
Zitieren
#10
problem erkannt...

mein iis7 scheint standardmäßig kein url rewriting zu unterstützen. hat das schonmal jemand konfiguriert?
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste