Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Img-Source ändern
#1
Hallo zusammen,
ich arbeite das erste mal mit WordPress und komme im großen und ganzen auch gut zurecht, allerdings habe ich ein Problem, bei dem ich nicht ganz durchsteige.

Folgende Situation:
Ich habe die Seite eines Kunden auf unseren Server übernommen, alles funktioniert und ich kann alle Contents bearbeiten. Einzige Ausnahme: Die Bilder in einem Slider.
Die alte Domain war auf SSL eingestellt, unsere ist es nicht.
Die Bilder im Slider sind nun das einzige (bisher) was nicht angezeigt wird. Andere Bilder werden dargestellt.
Sehe ich mir den HTML-Code im Browser an, wird als Source "https://..." angezeigt. Bei anderen Bildern ist ein relativer Pfad angegeben.

Nun meine Frage:
Wie kann ich die Source der Bilder in einem Slider ändern.

Bin für jeden Rat dankbar

LG Buzz
Zitieren
#2
Kommt drauf an, wie der Slider realisiert wurde. Wird dafür ein Plugin verwendet? Oder ist der vielleicht sogar in den HTML-Templates hardcodiert drin?
Zitieren
#3
Ein Plugin kann ich dazu nicht finden. Ich gehe erst mal davon aus, dass es Teil des Templates ist. Aber der Tipp mit dem HardCoding ist gut, das werde ich mir mal ansehen...
Zitieren
#4
Eventuell könnte es auch ein Feature des Themes sein. Eventuell gibt es Theme-Optionen dafür.
Zitieren
#5
(22.06.2016, 09:40)wolfgang schrieb: Eventuell könnte es auch ein Feature des Themes sein. Eventuell gibt es Theme-Optionen dafür.

Habe eine Option gefunden.
Interessanterweise ist hier die richtige URL angegeben (siehe Foto)

Ich denke mir, dass die URL in irgend einer PHP verwurstet wird...


Angehängte Dateien Thumbnail(s)
   
Zitieren
#6
Problem ist gelöst:
In einer .php (wp-content/themes/wordpress-bootstrap/page-homepage.php) war ein replace befehl eingebaut, der aus "http" "https" macht.
Ich weiß nicht, ob das von unserem Kunden so angelegt wurde, oder ob WP das so gebaut hat, aber es funktioniert jetzt.
Zitieren
#7
Das kam ziemlich sicher vom Kunden und war wohl dem Versuch geschuldet, alle Aufrufe von http auf https umzubiegen.
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste