Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[gelöst] Spamfilterfehlermeldung bei Powermail
#1
Hallo,

seit kurzen bekommen meine User beim Absenden eines Powermail-Formulars folgende Fehlermeldung:

Fatal error: Call to a member function setKey() on a non-object in /kunden/xxxxx/rp-hosting/xxxxxxx/xxxxxx/typo3cms/htdocs3/typo3conf/ext/powermail/Classes/Domain/Validator/SpamShieldValidator.php on line 473

typo3 6.2.9
powermail 2.1.15
wt_spamshield 1.3.0

472    protected function saveSpamFactorInSession() {

473        $this->typoScriptFrontendController->fe_user->setKey(
474            'ses',
475            'powermail_spamfactor',
476            $this->getCalculatedMailSpamFactor(TRUE)
477        );
478        $this->typoScriptFrontendController->storeSessionData();
479    }

Kann mir jemand einen Tip geben?
Wie kann ich im Notfall den Spamfilter für das Formular ausschalten?
Mit freundlichen Grüßen
Claus D. Metzner aus Hamburg
Zitieren
#2
Powermail-Update gemacht?

Falls ja:
1. Im Installtool einen Database Compare machen
2. Alle Cache-Dateien löschen, am besten auf der Shell mit dem Befehl rm -rf typo3temp/Cache/
Zitieren
#3
(12.02.2015, 16:41)wolfgang schrieb: Powermail-Update gemacht?

Falls ja:
1. Im Installtool einen Database Compare machen
2. Alle Cache-Dateien löschen, am besten auf der Shell mit dem Befehl rm -rf typo3temp/Cache/

Danke Wolfgang,

das war es.
Zur Frage konfigurieren des Spamfilters habe ich mir einfach noch mal deine Videoanleitung angesehen. Danke dafür.

Problem ist gelöst.
Mit freundlichen Grüßen
Claus D. Metzner aus Hamburg
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste