Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Installation Typo3 6.2 beta
#1
Hallo zusammen,

irgendwie habe ich ein kleines Problem mit der Beta von Typo3.

Im Video von Wolfgang ist alles sehr genau und nachvollziehbar beschrieben, doch nach der Installation hat Typo3 bei mir Darstellungsprobleme.

Das Backend der Seite kommt ohne Formatierung ganz weiß, nur mit ein paar unvollständigen Punkten im linken oberen Bereich.

Hat jemand von euch ähnliche Erfahrungen gemacht?

Liebe Grüße - insomnia


Edit - ich habe mal noch einen Screenshot angefügt ... Wink


Angehängte Dateien Thumbnail(s)
   
Zitieren
#2
So ein Fehler deutet meistens darauf hin, dass im Installtool der CompressionLevel für BE und FE > 0 ist, aber die entsprechenden Zeilen in der .htaccess nicht auskommentiert sind.
Zitieren
#3
Vielen Dank für die schnelle Info Wink

Da hab ich mir ja was vorgenommen, denn mit der htaccess habe ich bisher noch nicht so viel zu tun gehabt und mein Freund kann mir leider auch nicht helfen, da er sich zwar mit Webseiten, doch nicht mit Typo3 auskennt.

Die Zeilen für die Kompression sind doch diese hier:

Code:
### Begin: Compression via TYPO3 ###

# Compressing resource files will save bandwidth and so improve loading speed especially for users
# with slower internet connections. TYPO3 can compress the .js and .css files for you.
# *) Uncomment the following lines and
# *) Set $TYPO3_CONF_VARS['BE']['compressionLevel'] = '9' for the Backend
# *) Set $TYPO3_CONF_VARS['FE']['compressionLevel'] = '9' together with the TypoScript properties
#    config.compressJs and config.compressCss for GZIP compression of Frontend JS and CSS files.

#<FilesMatch "\.js\.gzip$">
#    AddType "text/javascript" .gzip
#</FilesMatch>
#<FilesMatch "\.css\.gzip$">
#    AddType "text/css" .gzip
#</FilesMatch>
#AddEncoding gzip .gzip

### End: Compression via TYPO3 ###

Die waren dann demnach schon bei bei mir auskommentiert.
Da aber dieser bereich im Quelltext irgendwie ein wenig komisch aussieht, denke ich fast, dass das schon bei Typo3 komprimiert übermittelt wird.

Code:
<title>New TYPO3 site [TYPO3 6.2.0beta1]</title>
<meta name="generator" content="TYPO3 6.2, http://typo3.org/, Kasper Skårhøj 1998-2013, extensions are copyright of their respective owners." />
<meta name="robots" content="noindex,follow" />
<meta http-equiv="X-UA-Compatible" content="IE=9" />

<link rel="stylesheet" type="text/css" href="../typo3temp/compressor/ext-all-notheme-c14773c8ba012fdc8b2134761b4d4f35.css?1384258826" media="all">
<link rel="stylesheet" type="text/css" href="../typo3temp/compressor/xtheme-t3skin-265d6029df39d21ebd99c1311f5599fc.css?1384258826" media="all">

<link rel="stylesheet" type="text/css" href="../typo3temp/compressor/merged-9efd9926b02eaa36db153cfdef4a0096-35ed1e7718df7a60dbfd30744fb20a7d.css?1384258826" media="all">
<style type="text/css">
/*<![CDATA[*/
<!--
/*inDocStyles*/






-->
/*]]>*/
</style>

<script src="../typo3temp/compressor/prototype-4c39adad16bec9c656ef9270399a10b0.js" type="text/javascript"></script>
<script src="../typo3temp/compressor/effects-7c96a46a70133aad5b34615d9452829b.js" type="text/javascript"></script>
<script src="../typo3temp/compressor/builder-b1083594d9d36d752343a023e7586393.js" type="text/javascript"></script>
<script src="../typo3temp/compressor/effects-7c96a46a70133aad5b34615d9452829b.js" type="text/javascript"></script>
<script src="../typo3temp/compressor/dragdrop-47e181e69ca4b70815b7d3ce45325a48.js" type="text/javascript"></script>
<script src="../typo3temp/compressor/controls-c6edf5aed815cf26192751af10e2a47c.js" type="text/javascript"></script>
<script src="../typo3temp/compressor/scriptaculous-0432058693f9a3a861333bf67a7ed702.js" type="text/javascript"></script>
<script src="../typo3temp/compressor/ext-base-4e13391b59d3b3954409d51495a10785.js" type="text/javascript"></script>
<script src="../typo3temp/compressor/ext-all-c684abb5f155c9188dd5cfd14a1db93f.js" type="text/javascript"></script>
<script src="../typo3temp/compressor/ext-lang-en-47c322955f3826011046376212b1c606.js" type="text/javascript" charset="utf-8"></script>
<script type="text/javascript">
/*<![CDATA[*/

Falls dies so sein sollte - man sehen wo ich die Komprimierung abschalten kann.

Liebe Grüße aus dem sonnigen Süden - insomnia
Zitieren
#4
Code:
#<FilesMatch "\.js\.gzip$">
#    AddType "text/javascript" .gzip
#</FilesMatch>
#<FilesMatch "\.css\.gzip$">
#    AddType "text/css" .gzip
#</FilesMatch>
#AddEncoding gzip .gzip

Hier musst du das Kommenarzeichen # entfernen, also auskommentieren. Momentan sind die Zeile einkommentiert. Oder verwechsle ich die Bezeichnung??

Auf jeden Fall die Rautezeichen entfernen Wink
Zitieren
#5
Leider hat das Entfernen der Kommentarzeichen in der .htaccess nicht gebracht.

Was mich auch ehrlich gesagt ein wenig stutzig macht ist der Code im Quelltext für die Styles:

Code:
<link rel="stylesheet" type="text/css" href="../typo3temp/compressor/ext-all-notheme-c14773c8ba012fdc8b2134761b4d4f35.css?1384258826" media="all">
<link rel="stylesheet" type="text/css" href="../typo3temp/compressor/xtheme-t3skin-265d6029df39d21ebd99c1311f5599fc.css?1384258826" media="all">

<link rel="stylesheet" type="text/css" href="../typo3temp/compressor/merged-9efd9926b02eaa36db153cfdef4a0096-35ed1e7718df7a60dbfd30744fb20a7d.css?1384258826" media="all">

Er sieht mir irgendwie ungewöhnlich aus, zumindest das was nach der .css-Dateiendung kommt.
Im Systemverzeichnis sind die CSS-Datei zumindest inclusive der .css-Endung vorhanden. Das was im Seitenquelltext steht, ist jedoch nicht vorhanden.

Evtl. könnte dies die Ursache sein, warum keine Styles geladen werden, aber soviel mittlerweile raus bekommen habe, hängen die Zahlen mit dem Caching zusammen.
In einigen Foren liest man, dass dies Probleme bereiten kann, doch bin ich mir nicht sicher, ob es hieran liegen könnte.

Ach übrigens - Sorry für die Wordpress-User, dass ich diesen Beitrag im Wordpress-Bereich gepostet habe. Eventuell kann man den ja zum Typo-Bereich verschieben.
Zitieren
#6
Danke für den Hinweiss mit dem falschen Board, war mir gar nicht aufgefallen Wink

Hast du denn mal im Install-Tool geschaut, wie die beiden Parameter für compressionLevel dort eingestellt sind? Setz die mal auf 0.

Dann müsste irgendwo in deinem Typoscript im config-Bereich stehen: compressCss = 1 und/oder concatenateCss = 1
Setze die auch mal auf 0.
Zitieren
#7
Dank Wolfgang für Deine Tipps, doch leider bin ich mit dem Thema nicht weiter gekommen.

Ist aber auch nicht so schlimm, da es ja zum "Probieren" war und ich mittlerweile erfolgreich die Typo 6.1. installiert habe.

Ich vermute weniger, dass mein Problem an Typo 6.2. sondern vielmehr an mir lag (z.Bsp. dass ich es als root installierte).
Generell geht es mir ja darum erste Erfahrungen mit Typo3 zu sammeln und dabei ist es mir nun ehrlich gesagt nicht so wichtig, ob es nun die 6.1.er oder die 6.2.er Version ist Wink

Liebe Grüße - insomnia
Zitieren
#8
Die 6.2er ist halt momentan noch nicht 100%ig stabil, und auch viele Extensions funktionieren noch nicht richtig. Das muss man im Hinterkopf behalten. Ist ja immer noch beta!
Zitieren
#9
Hallo,

ich hatte genau das gleiche Problem. Ich habe dann auch recht schnell herausgefunden an was das liegt. Allerdings suche ich nun eine Lösung, wie man das Problem abschalten kann.

Ich habe, als ich genau das gleiche weiße Backend hatte, gleich mal die Entwickler Tools gestartet(F12 bei Chrome) und siehe da.

Alle CSS und JS Dateien, im Ordner root/typo3temp/compressor, bekommen einen forbidden (403) Fehler, warum?

Ich gehe dann mal via FTP Client rein und sehe das alle Dateien in dem Ordner 660 chmod Rechte haben. Somit erklärt sich der 403 Fehler, nach dem manuellen umstellen, habe ich nun auch ein Backend.
Allerdings bekommen alle neuen Dateien, in dem Ordner, auch 660 Rechte, wie kann man das ändern bzw. an was liegt das?

//edit Wie ich nun herausgefunden habe sollten die rechte 660 eigentlich reichen, allerdings nur wenn der Besitzer der Webserver ist. Nun ist der Besitzer in meinem Fall der gleiche wie bei den anderen Dateien aber das scheint dort nicht richtig zu sein... ich forsche weiter

//edit² Ich habe mir nun mal das selbe Verzeichnis mal bei einer 6.1.7 Version angeschaut da werden die Dateien mit den Rechten 644 ausgestattet. Besitzer ist hier jedoch der gleiche wie bei der 6.2 beta5, liegen auch im gleichen Paket. Hier läuft alles reibungslos, weil das lesen von außen eben erlaubt ist. Kann es sein wenn ich TYPO3 via SSH installiere, dass die Dateien dann direkt den Webserver als Besitzer bekommen? Weil dann wäre genau da der Knackpunkt.

//edit³ Das in Rot markierte ist natürlich falsch, da mit den rechten der Zugriff von außen bzw. nicht Eigentümern/Gruppen verweigert wird.
Zitieren
#10
Hallo, du musst mit deinem Hoster die passende umask für deine Installation ausklambüsern.

Die kannst du dann im install Tool festlegen.

Gesendet von meinem GT-I9505 mit Tapatalk
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste