Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
cooluri -
#1
Hallo Forum,

nach stundenlangem Suchen und Lesen in anderen Foren erscheint mir dieses als am kompetentesten und deshalb stelle ich hier mein Problem vor:

server: Debian 5
typo3: 4.7.8
php: 5.3.8
cooluri: 1.0.35

Meine Ordnerstruktur:
/var/www/domain/
/var/www/typo3/

Inhalt der sites-available/default:
Code:
###/etc/apache2/sites-available/default###

NameVirtualHost Server-IP
<VirtualHost Server-IP>
    ServerAdmin postmaster@localhost
    
DocumentRoot /var/www
    <Directory />
        Options FollowSymLinks
        AllowOverride All
    </Directory>
    <Directory /var/www/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Order allow,deny
        allow from all
        # This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                RedirectMatch ^/$ /apache2-default
    </Directory>

ScriptAlias /cgi-bin/ "/usr/lib/cgi-bin/"
    <Directory "/usr/lib/cgi-bin">
        AllowOverride None
        Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
        Order allow,deny
        Allow from all
    </Directory>

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/log/apache2/access.log combined
ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

Inhalt der sites-available/domain
Code:
###/etc/apache2/sites-available/domain.tld###

<VirtualHost Server-IP:80>
        ServerName www.domain.tld
     ServerAlias domain.tld www.domain.tld
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/domain
        <Directory /var/www/domain/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>
        ErrorLog /var/log/apache2/error.log
        LogLevel warn
        CustomLog /var/log/apache2/access.log combined
        ServerSignature Off
</VirtualHost>

Inhalt der .htaccess in /var/www/typo3/
Code:
Options +FollowSymLinks
RewriteEngine On
RewriteBase /typo3/
RewriteRule ^/(typo3|typo3temp|typo3conf|t3lib|tslib|fileadmin|uploads|showpic\.php)/ - [L]
RewriteRule ^/(typo3|typo3temp|typo3conf|t3lib|tslib|fileadmin|uploads|showpic\.php)/.*$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteRule .* index.php [L]

und der Inhalt des TS-Setup:
Code:
page.baseURL = www.domain.tld
config.simulateStaticDocuments = 0
config.tx_cooluri_enable = 1
config.redirectOldLinksToNew = 1

Nach Installation und o.a. Konfiguration von cooluri und Aufruf von "http://domain.tld" erhalte ich folg. "schöne" URL in der Suchzeile, im Quellcode und in der Navigation:

"http://server-ip/typo3/seite.html"

Man kann sowohl mit "...index?id=Seiten-ID" als auch mit "http://server-ip/typo3/seite.html" die Seite erreichen.

Mein Ziel ist aber: "http://domain.tld/seite.html"

Aktivieren von "Seite in Mitte einer URL auslassen" in den Typo3-Seiteneigenschaften brachte keine Veränderung und wenn ich als Systemdatensatz eine Domäne einfüge, habe ich zwar in der Navigation und im Quellcode mein Ziel ("http://domain.tld/seite.html") erreicht, aber die Seite ist nur noch über "...index?id=Seiten-ID" aufrufbar (ansonsten kommt Fehler-404). Auch ein Aufruf über die Navigation ist nicht mehr möglich (ebenfalls Fehler-404).
Das Modul "mod-rewrite" ist installiert.

Wer kann mir helfen?

MfG.

telefix1
Zitieren
#2
In deiner .htaccess müsste eine Zeile mit RewriteBase stehen, entferne mal das Kommentarzeichen, ggf. musst du hier auch noch den Pfad anpassen. Vielleicht bringt das was.
Zitieren
#3
Hallo Wolfgang,

danke für die schnelle Antwort.

Du schreibst:

(01.11.2013, 18:48)wolfgang schrieb: In deiner .htaccess müsste eine Zeile mit RewriteBase stehen...

Steht schon da, hast es wahrscheinlich nur überlesen. Hab es schon mit und ohne Pfad versucht...
Wie gesagt, habe auch schon gefühlte 100 Std. Zeit investiert und alle möglichen Kombinationen ausprobiert...

MfG.

telefix1
Zitieren
#4
Ist denn "/etc/apache2/sites-available/domain.tld" auch aktiviert?

Weil wenn dürftest du dort ja kein TYPO3 sehen, wenn du domain.tld im Browser öffnest...

Mein Tipp: Aktiviere die o.g. Konfiguration, und veränder den DocumentRoot sowie die Directory Anweisung:

Code:
###/etc/apache2/sites-available/domain.tld###

<VirtualHost Server-IP:80>
        ServerName www.domain.tld
        ServerAlias domain.tld www.domain.tld
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/typo3
        <Directory /var/www/typo3/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>
        ErrorLog /var/log/apache2/error.log
        LogLevel warn
        CustomLog /var/log/apache2/access.log combined
        ServerSignature Off
</VirtualHost>

Anschließend nimmst du den RewirteBase aus der htaccess raus.
MfG René
Systemadministrator, Webentwickler

pantanet.de - pantamedia.com - gosna.de

Wishlist
Zitieren
#5
Nicht schlecht René,

mit Deinen (aktivierten Wink)Einstellungen und dem Aufruf "http://domain.tld" steht jetzt in der Adresszeile "http://domain.tld/home.html" - allerdings lande ich mit diesem Aufruf auf der Anmeldeseite zum Backend von T3. Huh

Komisch, komisch...

MfG.

telefix1
Zitieren
#6
Hast du die rewriteBase aus der htaccess raus genommen?

Gesendet von meinem GT-I9300 mit Tapatalk
MfG René
Systemadministrator, Webentwickler

pantanet.de - pantamedia.com - gosna.de

Wishlist
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste