Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem bei Update von 4.7.8 auf 6.0.2
#1
Nach dem Update von Version 4.5.23 auf 4.7.8 lief alles Problemlos ab. Nachdem ich aber die Source der 6.0.2 hochgeladen hatte, zeigten mit Front- und Backend verschiedene Fehler an, so dass ich weder auf die Seite, noch ins Installtool komme.

Folgende Meldungen sind zu sehen:

Frontend:
Fatal error: Class 'TYPO3\CMS\Extbase\Utility\ExtensionUtility' not found in /var/www/web736/html/www/typo3/sysext/indexed_search/ext_tables.php on line 11

Backend:


Fatal error: Class 'TYPO3\CMS\Extbase\Utility\ExtensionUtility' not found in /var/www/web736/html/www/typo3/sysext/indexed_search/ext_localconf.php on line 8

Hatte jemand schon eine ähnliche Meldung? Im Internet habe ich bisher keine Lösung gefunden.

PS: wenn ich die indexed_search in der localconf.php entferne, bekomme ich zwar Zugriff auf das Install Tool, sobald ich aber auf den Upgrade Wizard klicke, kommt folgende Meldung:

"Oops, an error occurred!

Invalid cache backend option "cacheTable" for backend of type "TYPO3\CMS\Core\Cache\Backend\Typo3DatabaseBackend""

Gruß

Norbert
Zitieren
#2
Hallo;

indexed_search ist inkompatibel mit 6.0. Das könnte dir häufiger passieren.

Ich würde alles deaktivieren, was nicht sysext ist und dann langsam nach und nach die erweiterungen aktualisieren und via em wieder installieren.

Backup versteht sich von selbst..

VG;
Cedric
Zitieren
#3
kann es eventuell auch an "suhosin.get.max_value_length: 512" liegen Huh

Seit der deaktivierung von indexed_search kommt im Frontend folgende Meldung: "Fatal error: Interface 'TYPO3\CMS\Extbase\Persistence\RepositoryInterface' not found in /var/www/web936/html/www/typo3/sysext/core/Classes/Resource/AbstractRepository.php on line 35"

PS: wenn ich die LocalConfiguration.php des Gouvernment Package anstelle der localconf.php, so kommt nur noch der Fehler

"Oops, an error occurred!

Invalid cache backend option "cacheTable" for backend of type "TYPO3\CMS\Core\Cache\Backend\Typo3DatabaseBackend"
Zitieren
#4
Kann es sein, dass diese Fehler durch in T3 6.0 nicht mehr unterstützte Extensions verursacht werden? Beim durchsehen meiner verwendeten Extensions fiel mir auf, dass unter anderem tan3glider und sk_fancybox in der aktuellen Version nicht mit der 6.0 funktionieren. HuhUndecided
Zitieren
#5
(26.02.2013, 14:07)virtualmachine schrieb: ..

indexed_search ist inkompatibel mit 6.0. Das könnte dir häufiger passieren.

Ich würde alles deaktivieren, was nicht sysext ist und dann langsam nach und nach die erweiterungen aktualisieren und via em wieder installieren.

..
Zitat:Kann es sein, dass diese Fehler durch in T3 6.0 nicht mehr unterstützte Extensions verursacht werden? Beim durchsehen meiner verwendeten Extensions fiel mir auf, dass unter anderem tan3glider und sk_fancybox in der aktuellen Version nicht mit der 6.0 funktionieren.

Ja
Zitieren
#6
Wenn die Seiten mit den eingebundenen Extensions Fehlermeldungen gebracht hätten, würde ich es ja noch verstehen, dass dann aber gleich das ganze t3 den Dienst versagt Undecided Confused

Danke für die Hilfe. Habe die Seite jetzt mit 4.7.8 am laufen und es funktioniert glücklicherweise Sleepy
Zitieren
#7
Das ist gut und freut mich für dich :-)

Es ist durchaus möglich, dass eine ganze Seite lahm gelegt wird, da der Programmcode der Erweiterungen uU schon geladen wird-und wenn das in die Hose geht, dann stottert der Motor.

Mit TYPO3 6.0 gabs vor allem eine große Änderung: PHP Namespaces.

Es gibt zwar eine Kompatibilitätsschicht, diese ist aber nur für Extbase-Erweiterungen; nicht aber für piBase Erweiterungen zu gebrauchen.
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste