Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem mit Startseite nach Installation coolUri
#1
Hallo,

ich möchte die Site http://www.tischler-loeffelsend.de/ in ein Typo3-CMS umwandeln.
Die Startseite des Testprojekts:
http://www.tischler-loeffelsend.de/typo3...index.html
Das Problem:
Seit ich coolUri installiert habe, kann das Projekt nicht mehr unter http://www.tischler-loeffelsend.de/typo3-loeffelsend/ aufgerufen werden (also Aufruf der Startseite mit weggelassenem index.html).

Typo3 Version 4.4.15

Relevante Teile des config-Bereichs:

baseURL = http://www.tischler-loeffelsend.de/typo3-loeffelsend/
absRefPrefix = http://www.tischler-loeffelsend.de/typo3-loeffelsend/
tx_cooluri_enable = 1
redirectOldLinksToNew = 1
}

Ich habe einen halben Tag vergeblich versucht den Fehler zu finden. In einem anderen Typo3-Projekt mit Version 4.6.8 tritt dieses Problem nicht auf. Könnte ein Update evtl. helfen? Vielen Dank für Eure Hilfe!

MfG

Th. Kraft
Zitieren
#2
Wenn ich statt
http://www.tischler-loeffelsend.de/typo3...index.html
,diesen Link aufrufe
http://www.tischler-loeffelsend.de/typo3.../index.php
dann funktioniert es.
Hast du CoolURI auch richtig konfiguriert?
Zitieren
#3
Entschuldigung, ich hatte vergessen, daß ich den Suffix .html in CoolUri gelöscht hatte. Das Problem noch einmal:

Die Startseite kann über
http://www.tischler-loeffelsend.de/typo3...send/index
(ohne das Suffix .html !!)
aufgerufen werden, aber nicht über das Verzeichnis
http://www.tischler-loeffelsend.de/typo3-loeffelsend/ (hierpage not found-Fehler)

Ich möhte ja später das Projekt auf die Domain www.tischler-loeffelsend übertragen, und dannn soll bei Aufruf dieser Domain kein Page not found-Fehler kommen.

Daß es mit http://www.tischler-loeffelsend.de/index.php klappt, ist klar.
Zitieren
#4
Hast du vielleicht irgendwo eine .htaccess liegen, in der DirectoryIndex gesetzt wird?
Zitieren
#5
Nein!
Zitieren
#6
Danke für Deine Hilfe!

Auch wenn ich im Verzeichnis die Anweisung einfüge

DirectoryIndex index.php

klappt es nicht.


Ordnerstruktur: /site/typo3-loeffelsend

In / und in site liegt keine .htaccess-Datei.


Im Moment sieht die .htaccess-Datei in typo3-loeffelsend so aus wie eine normale Typo3-htaccess-Datei, ergänzt um die Anweisung

AddType application/x-httpd-php53 .php .php5

, damit Typo3 4.6 bei Strato läuft.

Hier der Inhalt:

Code:
# PHP 5.3 benutzen
AddType application/x-httpd-php53 .php .php5
#####
#
# Example .htaccess file for TYPO3 CMS - for use with Apache Webserver
#
# This file includes settings for the following configuration options:
#
# - Compression via TYPO3
# - Settings for mod_rewrite (URL-Rewriting)
# - PHP optimisation
# - Miscellaneous
#
# If you want to use it, you have to copy it to the root folder of your TYPO3 installation (if its
# not there already) and rename it to '.htaccess'. To make .htaccess files work, you might need to
# adjust the 'AllowOverride' directive in your Apache configuration file.
#
# IMPORTANT: You may need to change this file depending on your TYPO3 installation!
#
# Lines starting with a # are treated as comment and ignored by the web server.
#
# You should change every occurance of TYPO3root/ to the location where you have your website in.
# For example:
# If you have your website located at http://mysite.com/
# then your TYPO3root/ is just empty (remove 'TYPO3root/')
# If you have your website located at http://mysite.com/some/path/
# then your TYPO3root/ is some/path/ (search and replace)
#
# You can also use this configuration in your httpd.conf, but then you have to modify some lines,
# see the comments (search for 'httpd.conf')
#
# Questions about this file go to the matching Install mailing list, see
# http://typo3.org/documentation/mailing-lists/
#
####


### Begin: Compression via TYPO3 ###

# Compressing resource files will save bandwidth and so improve loading speed especially for users
# with slower internet connections. TYPO3 can compress the .js and .css files for you.
# *) Uncomment the following lines and
# *) Set $TYPO3_CONF_VARS['BE']['compressionLevel'] = '9' for the Backend
# *) Set $TYPO3_CONF_VARS['FE']['compressionLevel'] = '9' together with the TypoScript properties
#    config.compressJs and config.compressCss for GZIP compression of Frontend JS and CSS files.

#<FilesMatch "\.js\.gzip$">
#    AddType "text/javascript" .gzip
#</FilesMatch>
#<FilesMatch "\.css\.gzip$">
#    AddType "text/css" .gzip
#</FilesMatch>
#AddEncoding gzip .gzip

### End: Compression via TYPO3 ###


### Begin: Browser caching of ressource files ###

# Enable long browser caching for JavaScript and CSS files.

# This affects Frontend and Backend and increases performance.
# You can also add other file extensions (like gif, png, jpg), if you want them to be longer cached, too.

<FilesMatch "\.(js|css)$">
  <IfModule mod_expires.c>
    ExpiresActive on
    ExpiresDefault "access plus 7 days"
  </IfModule>
  FileETag MTime Size
</FilesMatch>

### End: Browser caching of ressource files ###


### Begin: Settings for mod_rewrite ###

# You need rewriting, if you use a URL-Rewriting extension (RealURL, CoolUri, SimulateStatic).

<IfModule mod_rewrite.c>

# Enable URL rewriting
RewriteEngine On

# Change this path, if your TYPO3 installation is located in a subdirectory of the website root.
#RewriteBase /

# Rule for versioned static files, configured through:
# - $TYPO3_CONF_VARS['BE']['versionNumberInFilename']
# - $TYPO3_CONF_VARS['FE']['versionNumberInFilename']
# IMPORTANT: This rule has to be the very first RewriteCond in order to work!
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+)\.(\d+)\.(php|js|css|png|jpg|gif|gzip)$ $1.$3 [L]

# Basic security checks
# - Restrict access to deleted files in Recycler directories
# - Restrict access to TypoScript files in default templates directories
# - Restrict access to Private extension directories
# For httpd.conf, use these lines instead of the next ones:
# RewriteRule ^/TYPO3root/fileadmin/(.*/)?_recycler_/ - [F]
# RewriteRule ^/TYPO3root/fileadmin/templates/.*(\.txt|\.ts)$ - [F]
# RewriteRule ^/TYPO3root/typo3conf/ext/[^/]+/Resources/Private/ - [F]
RewriteRule ^fileadmin/(.*/)?_recycler_/ - [F]
RewriteRule ^fileadmin/templates/.*(\.txt|\.ts)$ - [F]
RewriteRule ^typo3conf/ext/[^/]+/Resources/Private/ - [F]

# Stop rewrite processing, if we are in the typo3/ directory.
# For httpd.conf, use this line instead of the next one:
# RewriteRule ^/TYPO3root/(typo3/|t3lib/|fileadmin/|typo3conf/|typo3temp/|uploads/|favicon\.ico) - [L]
RewriteRule ^(typo3/|t3lib/|fileadmin/|typo3conf/|typo3temp/|uploads/|favicon\.ico) - [L]

# Redirect http://example.com/typo3 to http://example.com/typo3/index_re.php and stop the rewrite processing.
# For httpd.conf, use this line instead of the next one:
# RewriteRule ^/TYPO3root/typo3$ /TYPO3root/typo3/index.php [L]
RewriteRule ^typo3$ typo3/index_re.php [L]

# If the file/symlink/directory does not exist => Redirect to index.php.
# For httpd.conf, you need to prefix each '%{REQUEST_FILENAME}' with '%{DOCUMENT_ROOT}'.
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

# Main URL rewriting.
# For httpd.conf, use this line instead of the next one:
# RewriteRule .* /TYPO3root/index.php [L]
RewriteRule .* index.php [L]

</IfModule>

### End: Settings for mod_rewrite ###


### Begin: PHP optimisation ###

# If you do not change the following settings, the default values will be used.

# TYPO3 works fine with register_globals turned off.
# This is highly recommended, if your web server has it turned on.
#php_flag register_globals off

### End: PHP optimisation ###



### Begin: Miscellaneous ###

# Make sure that directory listings are disabled.
#Options -Indexes

### End: Miscellaneous ###


# Add your own rules here.
# ...
Zitieren
#7
In der .htaccess findest du in einer Zeile RewriteBase. Entferne mal das kommentarzeichen und spiel hier ggf. mal mit dem Pfad rum.
Zitieren
#8
Hallo,

ich glaube nicht, daß es daran liegt, denn das Rewriting funktioniert ja. Ich habe es aber mit
RewriteBase / und
RewriteBase /typo3-loeffelsend/

jetzt getestet. Wieder "page not found".
Zitieren
#9
wie sieht denn deine CoolURI Conf aus?

Was mich wundert ist die erweiterung .php bei jeder unterseite, das ist unüblich. Normalerweise steht da .html.
eine index.php existiert auch auf dem FTP?

RewriteBase spielt erst eine Rolle, wenn du ohne das unterverzeichnis "typo3-loeffelsend/" arbeiten möchtest.

Weiterer Versuch: erweitere mal folgende stelle um index.php:

Orginal:
Code:
# Stop rewrite processing, if we are in the typo3/ directory.
# For httpd.conf, use this line instead of the next one:
# RewriteRule ^/TYPO3root/(typo3/|t3lib/|fileadmin/|typo3conf/|typo3temp/|uploads/|favicon\.ico) - [L]
RewriteRule ^(typo3/|t3lib/|fileadmin/|typo3conf/|typo3temp/|uploads/|favicon\.ico) - [L]

Angepasst:
Code:
# Stop rewrite processing, if we are in the typo3/ directory.
# For httpd.conf, use this line instead of the next one:
# RewriteRule ^/TYPO3root/(typo3/|t3lib/|fileadmin/|typo3conf/|typo3temp/|uploads/|favicon\.ico) - [L]
RewriteRule ^(typo3/|t3lib/|fileadmin/|typo3conf/|typo3temp/|uploads/|favicon\.ico|index\.php) - [L]
MfG René
Systemadministrator, Webentwickler

pantanet.de - pantamedia.com - gosna.de

Wishlist
Zitieren
#10
Hallo,

vielen Dank! Ich habe die .htaccess geändert - kein Erfolg. Das mit der Endung .php ist mir noch gar nicht aufgefallen. Vermutlich passiert, als ich gestern ein Update von 4.4.16 auf 4.5. gemacht habe.
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste