Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Seiten werden nicht angezeigt
#11
Sorry, hatte die letzten Fragen noch nicht vollständig beantwortet. Also der Seitenquelltext sieht in den relevanten Bereichen wie folgt aus (die a href-Werte sind [/b]übrigens unterstrichen und lassen sich anklicken. Dann wird der Seitenquelltext der Fehlerseite angezeigt.):

<div id="topnav" role="contentinfo">
<span><a href="login.html" onfocus="blurLink(this);">Login</a>&nbsp;|&nbsp;<a href="kontakt.html" onfocus="blurLink(this);">Kontakt</a>&nbsp;|&nbsp;<a href="impressum.html" onfocus="blurLink(this);">Impressum</a></span> </div>

<h1>YAML | &laquo;Simple Project&raquo; Template</h1>
<span>A YAML based Layout in a <em>ready to use</em> project structure</span>
</div>
<!-- begin: main navigation #nav -->
<div id="nav" role="navigation">

<div class="hlist"><ul><li class="active"><strong>Home</strong></li><li><a href="ueber-uns.html" onfocus="blurLink(this);">Über uns</a></li><li><a href="leistungen.html" onfocus="blurLink(this);">Leistungen</a></li><li><a href="anfahrt.html" onfocus="blurLink(this);">Anfahrt</a></li><li><a href="gaestebuch.html" onfocus="blurLink(this);">Gästebuch</a></li></ul></div>
</div>
<!-- end: main navigation -->
Zitieren
#12
Habe die Lösung gefunden. RealURL war in dem Typo3 4.4.6-Package, dass ich verwende, serienmäßig installiert. Eben deinstalliert. Jetzt geht alles.
Zitieren
#13
Aha, okay. Du hast das Introduction Package verwendet?
Zitieren
#14
Ja, genau das. Runtergeladen von typo3.org hatte ich introductionpackage-4.4.6a.zip.
Zitieren
#15
(02.02.2011, 14:01)Alexander schrieb: Jetzt werden die URLs bei Mouse over in der unteren Statuszeile des Browserfensters richtig angezeigt, aber außer Home ist keine Seite zu sehen.

Bei mir war es so ähnlich. Da Typo3 schon auf dem Webserver installiert ist, erschien beim Anklicken eines anderen Buttons "page not found".

Bin dann drauf gekommen, dass man nicht nur den cooluri-Cache leeren muss, sondern auch den Typo3-Cache "Alle Caches löschen".

Grüße

Zitieren
#16
Hallo,
ich habe ein Problem sowohl mit CoolUri wie auch mit RealUrl.
Das Problem gibt es nur auf einen Dedicated Server von 1und1 mit SuseLinux, apache2, php 5.3 ich habe weitere Dedicated Server bei Strato, da läuft alles bei gleicher Konfiguration.
Das Problem ist das scheinbar alles Funktioniert allerdings lassen sich keine Formulare mehr abschicken, wenn RealUrl oder CoolUri installiert und aktiviert sind.

Zudem kommt noch das externe Links (zumindest unter RealUrl) falsch umgesetzt werden. Ich habe dazu auch folgenden Bugfix gefunden:

Es kann vorkommen, dass Seiten mit dem Typ "Externer Link" bei der Verwendung von RealURL nicht auf die gewünschte Seite weiterleiten, sondern die aktuelle Seite einfach nur neuladen. Um dieses Problem zu beheben einfach in der "typo3conf/ext/realurl/class.tx_realurl.php" in der Funktion "function encodeSpURL(&$params, $ref)" vor der letzten Zeile folgendes einfügen: if($params['args']['page']['doktype'] == 3 && $params['args']['page']['url']){ switch($params['args']['page']['urltype']){ case 0: $preUrl = ''; break; case 1: $preUrl = 'http://'; break; case 2: $preUrl = 'ftp://'; break; case 3: $preUrl = 'mailto:'; break; case 4: $preUrl = 'https://'; break; } $newUrl = $preUrl.$params['args']['page']['url']; } $params['LD']['totalURL'] = $newUrl;

Nur wenn ich den Einfüge werden Links mal richtig mal falsch interpretiert. Auch das Löschen der RealUrl Tabellen und des gesamten Caches brachte keinen Erfolg.

Meine Vermutung ist jetzt, dass es mit der Serverkonfiguration zusammen hängen könnte, jedoch scheint das mod_rewrite zu funktionieren.
Was mich wuschig macht ist, dass es mal funktioniert und ohne dass ich was ändere plötzlich wieder nicht.

Wenn jemand einen Tipp hat für mich hat wo ich noch suchen kann, wäre ich sehr dankbar.
Zitieren
#17
Hallo,

wenn ich mich da mal einklinken darf: Ich habe prinzipiell dasselbe Problem. Alles nach Tutorial installiert, auch die CoolURI-URLs werden korrekt erzeugt, aber außer der Startseite kommt bei allen anderen Seiten ein Fehler. Meine Site liegt bei 1&1, da kommt:

------------------------
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webadmin@kundenserver.de and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
------------------------

An das Serverlog komme ich wohl leider nicht ran.

Wenn ich ihm die CoolURI-XML-Datei aus typo3conf wegnehme, geht nach einem Reload der Seite alles wieder normal, allerdings wieder mit den kryptischen URLs. Muss also ein Problem mit der XML-Datei sein...?
Über eine Lösung würde ich mich auch sehr freuen.

Ergänzung: Kein RealURL installiert, Typo3 4.5.10, CoolURI 1.0.26
Grundsätzlich installiert nach Wolfgangs Tutorial.

Grüße,
Frank
Zitieren
#18
Unterstützt dein 1&1 Webspace überhaupt mod_rewrite?

Kleiner Tipp am Rande: wechsel von 1&1 zu einem Hoster, der TYPO3 vernünftig unterstützt. 1&1 + TYPO3 = unnötiger Ärger! Ich spreche aus Erfahrung Wink
Zitieren
#19
Also bis jetzt geht erstaunlicherweise eigentlich alles ohne größere Probleme, obwohl ich vorher auch gelesen hatte, dass Typo3 auf 1&1 garnicht bis sehr schlecht gehen sollte. Die Site ist jetzt aber fertig, und ich muss sagen, es läuft alles so wie es soll, sogar eingermaßen schnell.
Nur eben die URLs noch nicht. Ich habe jetzt bei 1&1 gelesen, dass mod_rewrite unterstützt wird. Vielleicht ist ja noch ein Fehler in meiner .htaccess? Der mod_rewrite-Teil sieht im Moment so aus:

-------------------------
# Enable URL rewriting
RewriteEngine On

# Change this path, if your TYPO3 installation is located in a subdirectory of the website root.
# RewriteBase /cms

# Rule for versioned static files, configured through:
# - $TYPO3_CONF_VARS['BE']['versionNumberInFilename']
# - $TYPO3_CONF_VARS['FE']['versionNumberInFilename']
# IMPORTANT: This rule has to be the very first RewriteCond in order to work!
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+)\.(\d+)\.(php|js|css|png|jpg|gif|gzip)$ $1.$3 [L]

# Stop rewrite processing, if we are in the typo3/ directory.
# For httpd.conf, use this line instead of the next one:
# RewriteRule ^/TYPO3root/(typo3/|t3lib/|fileadmin/|typo3conf/|typo3temp/|uploads/|favicon\.ico) - [L]
RewriteRule ^(typo3/|t3lib/|fileadmin/|typo3conf/|typo3temp/|uploads/|favicon\.ico) - [L]

# Redirect http://example.com/typo3 to http://example.com/typo3/index_re.php and stop the rewrite processing.
# For httpd.conf, use this line instead of the next one:
# RewriteRule ^/TYPO3root/typo3$ /TYPO3root/typo3/index.php [L]
RewriteRule ^typo3$ typo3/index_re.php [L]

# If the file/symlink/directory does not exist => Redirect to index.php.
# For httpd.conf, you need to prefix each '%{REQUEST_FILENAME}' with '%{DOCUMENT_ROOT}'.
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

# Main URL rewriting.
# For httpd.conf, use this line instead of the next one:
# RewriteRule .* /TYPO3root/index.php [L]
RewriteRule .* index.php [L]

</IfModule>

### End: Settings for mod_rewrite ###

-----------------

Sollte ich da im Hinblich auf CoolURI irgendwas ändern? Bin da leider nicht so firm...

Grüße,
Frank
Zitieren
#20
Probier das:

RewriteBase /

am besten oben nach RewriteEngine On einbauen

Das würde aber nur passen, wenn die TYPO3 installation im Hauptverzeichnis deines Webspaces liegt, also wenn du durch den einfachen Aufruf deiner Domain direkt auf der TYPO3-Site landest. Falls TYPO3 in einem Unterverzeichnis liegt, teste mal

RewriteBase /das/unterverzeichnis
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste