Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem mit dem Wrap
#1
Hallo erstmal in die Foren Runde, schon Ewigkeiten her dass ich überhaupt ein Forum benutzt hab da mir meistens mein Freund Google bei allen Fragen geholfen hat.

Ich hab ein kleines Problem mit diesen Wraps, bei denen ich nicht ganz durchblicke. Aber von Anfang an, ich hab ein normales Menü, mit Untermenü, nichts aufregendes.

Code:
<!-- main_navigation -->    
<!-- Haupt Navigation -->  
<div class="band main_navigation">
    <nav class="container primary">
        <div class="sixteen columns">
            <ul>
                <li><a href="">Start</a></li>
                <li><a href="">Anreise</a></li>
                <li><a href="">Themen</a>
                
                    <ul>
                        <li><a href=""><span>- </span>Foto</a></li>
                           <li><a href=""><span>- </span>Reise</a></li>
                           <li><a href=""><span>- </span>Outdoor</a></li>
                    </ul>
                    
                </li>
                <li><a href="">Ausstellerverzeichnis</a></li>
                <li><a href="">Programm</a></li>
                <li><a href="">News</a></li>
            </ul>
        </div>
    </nav><!-- end container -->
</div> <!-- end band !-->
<!-- end main_navigation !-->

Klappt alles, dank wundervollem Video-Tutorial, nur bei einer Sache scheitere ich. Diese SPAN Container innerhalb des a Tags womit ich die Untermenüs kennzeichnen möchte.

Ich hab zwar das hier gefunden http://www.seo24.at/typo3-wrap-verstehen/ und allerhand herumprobiert, aber ich bekomms einfach nicht gebacken. Ich hoffe jemand von euch kann mir helfen. Hier noch der Typoscript Code
Code:
# Navigation main_navigation
lib.mainnav = HMENU
lib.mainnav {
  
wrap = <ul>|</ul>
  
  # 1. Ebene = Home
  1 = TMENU
  1 {
    expAll = 1
    noBlur = 1
  
    # Normal
    NO = 1
    NO.allWrap = <li>|</li>    
    NO.stdWrap.htmlSpecialChars = 1
    
    # Current
    CUR = 1
    CUR.allWrap = <li class="active">|</li>    
    CUR.stdWrap.htmlSpecialChars = 1

    }
  
  # 2. Ebene = normale Ebene
  2 = TMENU
  2 {
    expAll = 1
    noBlur = 1
  
    # Normal
    NO = 1
    NO.wrapItemAndSub = <li>|</li>
    NO.stdWrap.htmlSpecialChars = 1
    
    # Current
    CUR = 1
    CUR.wrapItemAndSub = <li class="active">|</li>
    CUR.stdWrap.htmlSpecialChars = 1
    
    # Aktiver Zustand
    ACT = 1
    ACT < .CUR

    }
  
  # 3. Ebene = 1. Unterebene
   3 < .2
   3.wrap = <ul>|</ul>
  
   3 = TMENU
   3 {
    expAll = 1
    noBlur = 1
  
    # Normal
    NO = 1
    NO.wrapItemAndSub = <li>|</li>
    wrap = <ul>|</ul>
    stdWrap = 123<span>55 | 5</span>
  }
  
}

Wie man sieht hab ich (letzte Zeile!) allerhand herum probiert, einfach um zu sehen wie wo was wann etwas im Quelltext aufscheint, nichts!

Das ist das Ergebnis mit oberen Script.
Code:
<!-- main_navigation -->    

<!-- Haupt Navigation -->  

<div class="band main_navigation">

  <nav class="container primary">

      <div class="sixteen columns"><ul><li class="active"><a href="index.php?id=1"  >Home</a></li><li><a href="index.php?id=5"  >Anreise</a></li><li><a href="index.php?id=6"  >Themen</a><ul><li><a href="index.php?id=10"  >Foto</a></li><li><a href="index.php?id=11"  >Reise</a></li><li><a href="index.php?id=12"  >Outdoor</a></li></ul></li><li><a href="index.php?id=7"  >Ausstellerverzeichnis</a></li><li><a href="index.php?id=8"  >Programm</a></li><li><a href="index.php?id=9"  >News</a></li></ul></div>

  </nav><!-- end container -->

</div> <!-- end band !-->

<!-- end main_navigation !-->
Und wenn ich schon beim dumm fragen bin, vielleicht kann mir hier auch noch jemand helfen, zumindest einen Ansatz, wo ich zu Suchen beginnen soll. Und zwar werden alle Links, egal wo, mit 2 leerzeichen am Ende im Quelltext angezeigt (siehe Code Box weiter oben), nicht weiter tragisch, aber stört mich doch irgendwie.

Ich hoffe jemand findet Zeit und ist so lieb um mir zu helfen.
Besten Dank schon mal Confused
Zitieren


Nachrichten in diesem Thema
Problem mit dem Wrap - von punctilio - 03.07.2012, 17:05
RE: Problem mit dem Wrap - von Daniel Ceballos - 03.07.2012, 18:52
RE: Problem mit dem Wrap - von punctilio - 03.07.2012, 19:09
RE: Problem mit dem Wrap - von Daniel Ceballos - 04.07.2012, 00:58

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste