Webdesign-Forum

Normale Version: tt_news Probleme mit Mehrsprachigkeit
Du siehst gerade eine vereinfachte Darstellung unserer Inhalte. Normale Ansicht mit richtiger Formatierung.
Hallo liebe Forenmitglieder,

ich nutze tt_news in einer zweisprachigen Website (Deutsch/Englisch). Die Wechsel zwischen Deutsch und Englisch klappen auch, nur leider nicht überall bei tt_news. Wenn man die Artikel auf der Detailseite in die andere Sprache (Deutsch nach Englisch / Englisch nach Deutsch) wechseln will, dann kommt eine Fehlermeldung 

Zitat:Oops, an error occurred!

Template could not be found at "EXT:news/Resources/Private/Templates/News/DetailNotFound.html".

Im Typo3-Systemlog sieht das dann so aus:
Zitat:Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1288087061: Template could not be found at "EXT:news/Resources/Private/Templates/News/DetailNotFound.html". | TYPO3\CMS\Fluid\View\Exception\InvalidTemplateResourceException thrown in file /var/www/typo3cms/typo3_src-7.6.16/typo3/sysext/fluid/Classes/View/StandaloneView.php in line 402. Requested URL: https://www.example.com/en/news/article/

Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1288087061: Template could not be found at "EXT:news/Resources/Private/Templates/News/DetailNotFound.html". | TYPO3\CMS\Fluid\View\Exception\InvalidTemplateResourceException thrown in file /var/www/typo3cms/typo3_src-7.6.16/typo3/sysext/fluid/Classes/View/StandaloneView.php in line 402. Requested URL: https://www.example.com/aktuelles/artikel/

Das Wechseln der Sprache auf der Listenansicht der tt_news klappt dagegen fehlerfrei. Es ist also nur innerhalb der Dateilseiten, obwohl die Übersetzungen angelegt sind und auf dem Weg eines früheren Sprachwechsel aufrufbar sind.

Woran liegt das und wie lässt sich das beheben?

Liebe Grüße

Vanessa