Webdesign-Forum

Normale Version: tt_news, rss-feed, facebook
Du siehst gerade eine vereinfachte Darstellung unserer Inhalte. Normale Ansicht mit richtiger Formatierung.
Hallo,

ich habe bei meinem Projekt (http://www.cafelecca.de/cms/index.php) ein Problem: tt_news meldungen sollen über einen rss-feed (http://www.cafelecca.de/cms/index.php?id=73&type=100) und die facebook-anwendung dlvr.it an facebook übergeben werden. Im Prinzip funktioniert das auch, nur dass ich auf der facebook-test-seite (http://www.facebook.com/hdrein.dummie) in den Nachrichten weder Formatierungen noch Bilder bekomme. Hat jemand eine Idee, wie ich diese Formatierungen hinkriegen kann?

    TYPOSCRIPT Programming
  1. # RSS2
  2. rss2 = PAGE
  3. rss2 {
  4. typeNum = 100
  5. 10 >
  6. 10 < plugin.tt_news
  7. 10.pid_list >
  8. 10.pid_list = {$plugin.tt_news.pid_list}
  9. 10.singlePid = {$plugin.tt_news.singlePid}
  10. 10.defaultCode = XML
  11. 10.displayXML.xmlFormat = rss2
  12. #wenn man archivierte News nicht mehr RSSen will
  13. 10.archive = -1
  14. config {
  15. disableAllHeaderCode = 1
  16. additionalHeaders = Content-type:text/xml
  17. no_cache = 1
  18. xhtml_cleaning = 0
  19. }
  20. }
  21. #RSS 0.91
  22. rss091 = PAGE
  23. rss091 < rss2
  24. rss091 {
  25. typeNum = 101
  26. 10.displayXML.xmlFormat = rss091
  27. }
  28. #RDF
  29. rdffeed = PAGE
  30. rdffeed < rss2
  31. rdffeed {
  32. typeNum = 102
  33. 10.displayXML.xmlFormat = rdf
  34. #RDF kennt auch Feed-Images
  35. 10.displayXML.xmlIcon = fileadmin/templates/images/rss_high.gif
  36. }
  37. #Atom
  38. atom1 = PAGE
  39. atom1 < rss2
  40. atom1 {
  41. typeNum = 103
  42. 10.displayXML.xmlFormat = atom1
  43. }
  44.  
  45. page.headerData.110 = HTML
  46. page.headerData.110.value = <link rel="alternate" type="application/rss+xml" title="Titel des Feed" href="http://www.cafelecca.de/cms/index.php?type=100">
  47.  
  48. #<p class="bodytext"> für Content nur in LIST
  49. plugin.tt_news.displayList.content_stdWrap.parseFunc < tt_content.text.20.parseFunc



Vielen Dank und Grüße
Henning
Ich denke das liegt an folgender Stelle:

Code:
</description>
<img src="uploads/pics/004_02.png" width="688" height="1017" border="0" alt=""/>
<category>Allgemein</category>

Das Bild wird nicht mit vollem Pfad angezeigt, deswegen wird er es nicht finden.

Versuch es mal mit folgendem Code:

Code:
rss2 {
  config.absRefPrefix = http://www.cafelecca.de/cms/
}
rss091 {
  config.absRefPrefix = http://www.cafelecca.de/cms/
}
rdffeed {
  config.absRefPrefix = http://www.cafelecca.de/cms/
}
das Problem mit fehlenden Absätzen und Links im RSS-Feed wird so nicht behoben. Ich denke ich muß irgendwo/ irgendwie dem RTE ein paar Formatierungen mitgeben. Aber alles, was google mir in der Hinsicht geliefert hat, funktionierte nicht.

Was die Weiterleitung der Bilder auf Facebook über dlvr.it angeht kann ich leider nichts testen, da die APP offline zu sein scheint. Kennt jemand eine bessere alternative?
Korrektur: weder bilder noch zeilenumbrüche noch absätze noch links werden auf der FB-Seite angezeigt :-(