Webdesign-Forum

Normale Version: days auf Tage umstellen
Du siehst gerade eine vereinfachte Darstellung unserer Inhalte. Normale Ansicht mit richtiger Formatierung.
Hallo zusammen,

sitz nun schon seit Tagen an diesem Problem.
Habe ein Archiv angelegt und Beiträge dort eingefügt.

Nun steht da ja wie lange der Beitrag schon online ist:
"28.05.2012 11:15 Alter: 23 days"

Probiere nun schon eine weile das days in Tage zu ändern, habe folgenden TypoCode eingefügt:
plugin.tt_news.[displayList|displaySingle|displayLatest].age_stdWrap.age = Minute(n)|Stunde(n)|Tag(e)|Jahr(e)

Auch die Sprach steht auf Deutsch:
config.language = de
config.locale_all = de_DE.UTF8

Hat einer eine Lösung oder kennt das Problem, würde mich über Feedback freuen.

Viele Grüße
Andi
Nur so als Frage: hast du das echt so mit den eckigen klammern und dern pipes angegeben? Wäre mir neu das dies so funktioniert.

Gesendet von meinem HTC Desire HD mit Tapatalk 2
Ja, habe es so angegeben.
Habe es aber auch so probiert:
plugin.tt_news.displayList.age_stdWrap.age = Minute(n)|Stunde(n)|Tag(e)|Jahr(e)
Bin gleich an meinem Rechner und schau mal.

Klappt das mit den eckigen klammern? Weißt du das oder hast du das einfach mal so gemacht?

Gesendet von meinem HTC Desire HD mit Tapatalk 2
Schon mal Danke.

Habe es hier gefunden.
http://www.moroli-media.com/buglog-singl...cb83e79c71
So... hab mir das ganze noch mal angeschaut. Bei mir hat es völlig ausgereicht folgendes zu definieren:

    TYPOSCRIPT Programming
  1. plugin.tt_news.displaySingle.age_stdWrap.age = " Minuten | Stunden | Tage | Jahre | Minute | Stunde | Tag | Jahr"
  2. plugin.tt_news.displayList.age_stdWrap.age = " Minuten | Stunden | Tage | Jahre | Minute | Stunde | Tag | Jahr"



Vielleicht hängt es ja mit den Anführungszeichen zusammen, die bei dir nicht vorhanden sind.

Übrigens klappt es wie erwartet nicht mit den Eckigen Klammern:

Code:
Fehler und Warnungen
2:    Line 5123: Object Name String, "plugin.tt_news.[displaySingle|displayList].age_stdWrap.age" contains invalid character "[". Must be alphanumeric or one of: "_-."
Habs mal eingebaut, aber keine Änderung. Huh

Hab eine externe TypoScript seite, ist es besser wenn ich den Code direkt dort einfüge wo ich das Plugin einfüge?

Mein Archiv habe ich als Standard Listeansicht(List) eingerichtet.
WinkWinkWinkWinkWinkWink
juhu, es läuft.

Habe es nun direkt auf die Seite wo ich das Plugin für die Single Ansicht eingefügt habe integriert und schon gehts Smile

Vielen Dank für Deine Hilfe